Music Maker update 31.0.4.50

ralftaro wrote on 3/15/2023, 7:12 AM

Hi all,

Music Maker update 31.0.4.50 went live today. Please find below the official patch notes.


Changes in patch 31.0.4.50 compared to 31.0.4.35

  • Crash during smart preview of TAK files fixed
  • Implementation to prevent peakmeter crashes changed
  • Adjustments made for improved crash evaluation
  • Error dialog handling for audio record/playback errors changed
  • MIDI editor menu bar sometimes not visible fixed


As always, the patch will be deployed via the program's automatic update function, which you can also trigger via the "Update program online" option in the "Help" menu. (In more current product generations, this will take you to the start dialogue to trigger the patch download.)  Please keep in mind that, under the current Music Maker product concept, you'll be able to patch your way up to the current product generation and revision from any version starting in generation 25.x of the software.

 

Comments

michael-simmons wrote on 3/15/2023, 8:40 PM

Patch does not install!! I get a "dear customer, the patch cannot be installed error page and to contact support, which I did. When is Magix going to ever fix this bugged out software? My undo button has been frozen for weeks, it consistently cuts out and I lose my work. So I patiently wait for the patch that goes live today and that doesn't work either!!! What the heck is going on at magix???

browj2 wrote on 3/16/2023, 5:22 PM

@michael-simmons

Hi,

I have updated both my desktop and laptop to 31.0.4.50 with no problems whatsoever. Both work fine

I have not had any problems with Undo with either the previous patch or this one.

There must be some other problem on your end - hardware, OS or anti-virus software.

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

ralftaro wrote on 3/17/2023, 7:01 AM

Hi all,

Michael had a support ticket with us and ended up being able to install the patch. Unfortunately, I cannot even fathom exactly what step of the patch installation procedure could produce that kind of error message - even in theory. However, if anybody actually finds themselves in the situation where they are having a problem with the automatic patch installation (e.g. with the main application not terminating properly to run the patch installer), they are always welcome to manually download and run the patch from this link:

https://ssl-update.magix.com/patch/music-maker-free-31-0-4--1678444651

Please note that this is just a smaller, incremental patch - not a full program installer this time. So, you would already have to be on the previous version to successfully install it.

Hope this helps!

 

Miguel-Andrade wrote on 3/18/2023, 11:15 AM

Hi, is it just me? Each time I try to work, my Musicmaker turns incredibly slow after a few "moves", there is no realtime interaction, I have to close (2 minutes just to get it closed) and turn on again !! Is there anyone that can help? Thanks

johnebaker wrote on 3/18/2023, 11:19 AM

@Miguel-Andrade

Hi

Assuming you are running Windows 11, check in Windows settings, Accessibility, Text cursor, Text cursor indicator is turned off.

HTH

John EB
Forum Moderator

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Paul-Nicol wrote on 4/4/2023, 9:23 PM

I have had trouble for weeks with crashing and in the last week have been trying to install a vst (Brushify). The sound drivers do not work well if at all. It got to the point the program would not even load today. Had to redo the ini a few times. (sound drivers missing) Then I see you have a beta post so decided to try it. Now I am getting one instrument on my speakers (third party drum machine (Brushify) and the midi file (piano) for that vst in my headphones. It is on the Magix low latency 2016. If I change to the Realtek ASIO it works but has a scratchy sound to the drum machine mostly when using the kick drum but if the file is busy enough the scratching can be triggered by any sound but the kick is the strongest. I cannot use the Music Maker ASIO as it seems to have removed itself some where in the couple of installs. It is in the drop-down but does not actually appear when selected. Earlier today I was using Music Maker ASIO (before it disappeared and most of the scratching was because of it and less in Realtek. Now Realtek is a problem.

I have been running the program for over a ½ hour and no crashes so far. Just bad sounding drums...

Update: I installed the patch (forgot in initial installation earlier) and now the drums sound fine but I played them continuously for 5 minutes along with a track and when I stopped the drum sound was all scrambled like a radio tuned slightly off station. Re-selected the Realtek ASIO again and it all went back to normal.

I will give it a run again tomorrow and report back with any findings.

Windows 10 Pro Dell M6800

Paul-Nicol wrote on 4/4/2023, 9:30 PM

Quick update to last mail. I have found the scratching again, it has just moved to other keys on my AKAI MPK mini.

browj2 wrote on 4/4/2023, 10:15 PM

@Paul-Nicol

Hi,

Not sure if this will help, but try going to the Program Settings, Audio/MIDI tab and increasing the Buffer number from 4 to 6.

Please let me know if this helps. If it does, you will have to set it each time that you go into Music Maker.

@ralftaro

Hi Ralf,

Music Maker does not retain changed Audio buffer settings from one session to the next. Would it be possible to have this corrected?

Thanks,

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

Paul-Nicol wrote on 4/5/2023, 6:30 AM

I wrote my update here last night and when I went back to the program it had restarted itself. Used it for a minute and set the ASIO again as it had dropped itself again. Then I changed to browser which had now lost sound all together. Music Maker shutdown again. I called it a night. Saw the reply to my query and tried to open the program to try it (I had done it before but not on this new beta as I expected it to work). Well the program keeps shutting down and restarting over and over. And when it is loading it takes about a minute to do so. It's like it is looking for something, can't find it so error trapping sends it some where else and it looses it's mind (or error trapping is not where it should be and it simply steps through it's sub). Not sure what to do now. The program was always a little unstable but I can't even get it to run now.

emmrecs wrote on 4/5/2023, 8:00 AM

@Paul-Nicol

Please follow this tutorial to, hopefully, find the cause of the crashes/failures to start. If you screenshot or copy and paste the full report here we may well be able to offer advice on how to avoid the problems!

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, NVidia GTX 1660TI and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, PhotoStory Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition 3, CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D, Akaso EK7000 Pro Action Cam

Paul-Nicol wrote on 4/5/2023, 8:15 AM

The latest crash from this morning.

 

johnebaker wrote on 4/5/2023, 10:00 AM

@Paul-Nicol

Hi

The performance log shows the faulting module is rthdasio64.dll - this is the Realtek HD audio card ASIO driver.

Check that the Realtek audio has the latest drivers, and if they are up to date, then try reinstalling them - note get them from Realtek, I found the Microsoft drivers for my Realtek HDA card were 'limiting' the inputs/outputs available.

@browj2

Hi John

I reported the issue with the number of buffers not being retained a while ago to Magix.

When you change the number of buffers the new setting is saved in the MusicMaker.ini file, however on next start of MMM the setting is ignored - ie it defaults to 4 and will reset the ini file value to 4 if you do not change it.

John EB
Forum Moderator

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

browj2 wrote on 4/5/2023, 10:52 AM

@johnebaker

Hi John EB,

Thanks. I had tried the same trick with the ini file without success. Strange.

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

Paul-Nicol wrote on 4/5/2023, 11:42 AM

Installed realtek driver from Dell. Did not correct anything. Still failed.
Installed realtek driver from Realtek.com Endless loop of remove but never install
Tried to reinstall Dell driver. Not it will not install as it gets in an endless loop
I have no realtek driver on the computer at this point...
Ran Music Maker. Worked with no driver but tried to apply a driver (Music maker ASIO) to see if any difference as now I could actually select that driver. Scratchy sound. Tried to reset back to no driver. Program informed me that it was picking direct. Hung up solid. Had to go to task manager and end it. No record of crash so it was instant death. Restarted and wanted to try setting buffers to 6. Froze up again. Waited to see if it would work again. It did but nothing functional. Started it again. Program tried to load a couple of itself. Got back to one instance. Set buffer to 6 then 8 and no difference on scratchy sound. Tried to select no driver just wave. Crash and loads this page (happens after every crash) "MUSIC MAKER: Free Song & Beat-Making Software for Everyone (magix.com)". Did get this crash report.

Should I go back to a normal install program at this point? the beta isn't working for me, not that the other is either.

 

Paul-Nicol wrote on 4/5/2023, 11:44 AM

Now I can't up load the error report...

 

Paul-Nicol wrote on 4/5/2023, 11:47 AM

Description
Faulting Application Path:    C:\Program Files\MAGIX\Music Maker\31\MusicMaker.exe

Problem signature
Problem Event Name:    APPCRASH
Application Name:    MusicMaker.exe
Application Version:    31.0.4.50
Application Timestamp:    640b32e4
Fault Module Name:    StackHash_ddb3
Fault Module Version:    10.0.19041.2788
Fault Module Timestamp:    2f715b17
Exception Code:    c0000374
Exception Offset:    PCH_F6_FROM_ntdll+0x000000000009DBB4
OS Version:    10.0.19045.2.0.0.256.48
Locale ID:    4105
Additional Information 1:    ddb3
Additional Information 2:    ddb325c782f9867194fa07e8e74e37cf
Additional Information 3:    6e22
Additional Information 4:    6e22f986a28ab6dd589a5a4c5b33cb85

Extra information about the problem
Bucket ID:    2f9cde75d3a99ae60bedb3c2bbd78bce (2012462257460972494)

johnebaker wrote on 4/5/2023, 2:10 PM

@Paul-Nicol

Hi

Thanks for the crash log data - the faulting module,  StackHash, would suggest that this is a Windows or RAM memory issue.

Check your Windows installation following this tutorial steps 3 - 11.

Given the age of this laptop, RAM issues could either be faulting RAM or overheating due to reduced fan/cooling efficiency. To check the RAM see this Dell article.

HTH

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Paul-Nicol wrote on 4/5/2023, 7:28 PM

I have totally rebuilt the computer between two years ago and last year. New ssd internal drives. New networking upgraded ram to max capacity from dell. Upgraded to windows 10 just shy of two years ago. No other programs malfunction at all. I will try another re-install of Music Maker (non-beta) tomorrow and also try and get the Realtek driver to install. I will get back to you tomorrow.

chip-stuebner wrote on 4/7/2023, 3:33 AM

I don't know if this will help but when an install or a download starts to loop it can indicate a problem with the harddrive. trouble with read/write. low hard drive space, bad spots on the drive or even the mechanism failing. you can do a hard drive health check to see if this is the case.

 

 

chip-stuebner wrote on 4/7/2023, 4:06 AM

I have a 2 small issues after the install of all updates. the pitch range has to be turned on in the arranger every time I exit and go back into MM2021. The loop window that shows the loop description, BPM, and pitch fields can not be adjusted to reveal the full description of the loop. this disrupts the workflow as when I look for a spiccato or legato I have to listen to each loop to find them. will there be a fix or am I doing some thing wrong? By the way, I was not happy with the lay out change from the original MM2021 with the updates because I had figure out where everything was, but I got over it. I have been with MM since 2016 and still think it is the easiest and most satisfying DAW I have ever used. also wish magix would go back to doing their own score loops not the construction kits. I have every one that Magix has made plus loops unlimited and have only seen one score genre put out in 6 months.

Vitalicus wrote on 4/23/2023, 4:47 PM

No IN-OUT range. Song play only from start. App restart dont help
What shotcut are for IN-OUT range?

SP. wrote on 4/23/2023, 6:16 PM

@Vitalicus You can try to click on the magnifying glass icon in the bottom right corner of the arranger window and then switch to another view mode. This should reset the loop region.

Vitalicus wrote on 4/25/2023, 5:40 AM

@Vitalicus You can try to click on the magnifying glass icon in the bottom right corner of the arranger window and then switch to another view mode. This should reset the loop region.

This don't help